Not compatible? Rated 3 out of 5 stars

As always recommended by the Mozilla migration assistant, this extension needs to be compatible with all versions.Surprisingly, it is not for 3.3a3

This review is for a previous version of the add-on (1.2.4).