Rated 4 out of 5 stars

I cannot install this as it says it is not a compatible extension with FireFox 3.5.3. I love this extension but with the most recent Firefox udate it broke.

This review is for a previous version of the add-on (0.18.1). 

fixed

Sorry, there was a tiny error in one of the configuration files that under certain circumstances would prevent the extension from installing on 3.5.*.
I just uploaded a new version 0.18.2 that fixes it. As soon as is reviewed, you can download it. (If you don't want to wait, rename the .xpi file to .zip, open it, extract install.rdf and open it with a text editor, find the the line containing the tag maxVersion and change its content from 3.2a1pre to 3.6a1pre, save it and overwrite the install.rdf within the zip archive, close the zip and rename it to .xpi, open the .xpi in firefox)