Well......I don't know what to say, but Rated 1 out of 5 stars

5.0 Version is a disaster. Why you delete all the config while updating? Why import / export function has been took out? Why the interface is so shitty?

I appreciate all your work have been done but now I just want to uninstall this add-on.

DONT DELETE THIS Rated 1 out of 5 stars

WHY ARE U DELETING BAD COMMENTS ABOUT LAST UPDATE ????????????????

there were 56 this morning ... and one of those were mine ... now there are only 41 ...

THIS IS NO WAY OF RESPONDING TO BAD DECISION ON YOUR PART AND RELEASING A FAULTY NEW VERSION

This user has a previous review of this add-on.

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

Rated 5 out of 5 stars

5.0 is so bad,Don't update to this Rated 1 out of 5 stars

all proxy config lost
and disable actually not work.
after enable always enable.
Trun off All proxys not work too.

ho

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

Lost proxy settings after automatic update Rated 1 out of 5 stars

After FoxyProxy was updated automaticly, it also DELETED all my proxy settings. It is unbelievable in 2017 that the developers posted an update that breaks your current settings, without warning. Was this thing even tested. How unethical can you get, esp if a business needs to use proxys for testing.

Also, for user settings, it doesn't even obfuscate passwords. So not only is this broken, but also insecure, so lovely eavesdroppers can see your passwords.

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

Another problem... Rated 3 out of 5 stars

Sorry to pile on. As a dev I know how shitty a major upgrade can be. But here's a MAJOR problem - if you happen to be using FoxyProxy when it updates, it will be stuck in on mode with no way to turn it off until you donwgrade it and turn it off. I was not able to use my Firefox without having BurpSuite open to forward my proxy requests.

Plus I can't stand the new interface - it's clumsy, OR how the button has moved to the right of the search box, the various icons indicating status, etc. Really don't like the web based stuff I much prefer the windows forms. Yeah Im sticking with 4.6.5 for a while.

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

Version 5 a disappointment Rated 1 out of 5 stars

I've been using FoxyProxy for years and loved it's ease of access and quick switching through right click on the icon.

With update to version 5, not only have I lost the quick access option (and several other features), but all my proxy settings are all gone. It is rather frustrating to lose all your settings. I had a rather large number of proxies and patterns.

I will be disabling FoxyProxy. The new interface, though pretty is unnecessary change.

Version 5 should not have been released, not until all the features have been implemented. It is several steps backwards.

Either way, it is for free and so thanks for the hard work and the years of usage.

How to get your settings again

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

5.0是非常糟糕的版本 Rated 1 out of 5 stars

非常差,pac都不支持

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

Functionality completely lost Rated 1 out of 5 stars

I've been using like 4 or 5 different customs proxies (I travel a lot with my computer, so I'm used to use different SSH tunnels in order to have a clean browsing experience besides the place I use internet). Now I've completely lost all the configurations with the new version 5. Also, very dissapointed with the integration, Not the easiest way to add different proxies nor the way one can change from using one to another.
A completely disaster.
Please, fix this huge issue.

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

Functionality lost in the new version Rated 1 out of 5 stars

I'm very dissapointed with the last update of this plug-in. Before, I have the option to choose with proxy to use. Now, this is completely lost.
Moreover, the configuration that I have with several proxys and exceptions is completely lost.
I will uninstall it as this FoxyProxy plug-in is now completely useless for my needs.

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

New version is a disaster Rated 1 out of 5 stars

The upgrade to v5 erase all the existing configuration, without warning or possibility to recover it.
The UI of this new version is a disaster.
And some great functionalities have been lost along the way, like the simple-but-awesome coloring of the icon when resolving an URL.
Very unprofessional move from the dev team...

Edit: Thanks to NeryK, I downgraded to v4.6.5 and recovered my previous conf. And I'm never upgrading it back again.

PSA - YOUR SETTINGS ARE NOT LOST (YET) Rated 1 out of 5 stars

So the 5.0 update is completely brain-dead, but you can still get your configuration back.

Just downgrade to v4.6.5 : https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/
Then backup your data this time around :)

Also this is a short-term workaround as Firefox will disable all legacy Add-ons in November.

DO NOT INSTALL VERSION 5.0 - UTTERLY BROKEN Rated 1 out of 5 stars

Not only does it lose all VPN configurations, which is understandable since it is completely rewritten for Firefox 57.

The worst part is that it is completely devoid of features. It does not even have a basic feature of excluding URLs from the proxy. Either everything goes through the proxy, or nothing goes through the proxy.

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

This is not serious Rated 1 out of 5 stars

After years using this extension now this update drops every feature I was using.
Don't update!

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

Don't update to 5.0! Rated 1 out of 5 stars

I am using Firefox more than 5 years - almost from the moment I have started using Firefox. I always enjoyed it's interface, possibility to switch proxy profiles - both manually and automatically, possibility to export settings.

Now with update to 5.0 we lost it all.
1. All settings are lost.
2. Import button does not work.
3. The interface is really ugly: it differs from overall interface of Firefox, now reaction on right button click, no possibility to view all proxy profiles etc.
4. Questionable "syncing" of proxy settings - I really don't need it as I can export settings in a cloud and import it on all my PCs.

Have to switch back to 4.6.5 and disable updating. Shame to developers!

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

Lost config Rated 1 out of 5 stars

What?! My proxies have been swept away! Damn! And the interface is really really ugly.... Let me turn on and off a single proxy from the toolbar, as it was before! "turn all proxies on/off" is absolutely futile!

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

lost config, missing features, nasty UI Rated 1 out of 5 stars

This update to v5 is terrible. It loses all the config, no longer has features I rely on such as forwarding DNS requests through the proxy, and the UI looks like it's designed for kids. Hopefully they'll bring features back to what it was capable of before.

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

Great Add-on until (not including) version 5 Rated 1 out of 5 stars

FoxyProxy was an essential productivity tool for me until they released version 5. The previous versions were great with excellent features. The features are gone in version 5. The configuration is gone aswell.
The new version does not have the features i need anymore and the ui is horrible.
Gone from five stars to one star.
Auto Updating to an incompatible version, which loses all configuration, and which does not provide the configuration options from the old version was an horrible choice.

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

From Great Design to Worst possible Design in v5 Rated 1 out of 5 stars

I'm sorry, but you turned FoxyProxy from a previously awesome into a below-average addon usability-wise. Here's why:

This update deleted ALL configurations I had. It's a fresh start now, and thanks to automatic updates, I got no warnings at all. I cannot import a backup, too! That feature is coming later, apparently. This combination is a NO-GO for me! You lost my trust in FoxyProxy from a data-security point.

You also removed a powerful feature: A click on the icon and then select a specific proxy for when you do not want to create a lot of new patterns for a specific bunch of sites you will probably just visit once.

Also, a lot more inefficiency when managing proxies and patterns. The interface feels really bloated to me now instead of lean and powerful.

Overall, v5 makes me wonder whether I should keep FoxyProxy or go for other solutions.

Frankly, I am disappointed.

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)

DNS not pass proxy after update Rated 3 out of 5 stars

After update to new version, the DNS request didn't pass proxy. Plz fix it;

how to get old version and your old settings

Please revert to the old version by:

1. Uninstall the version you have now (type about:addons in the address type and remove FoxyProxy)
2. Install the one version from here: https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/ you want version 4.6.5
3. Your old settings will magically reappear

This is a temporary solution--that older version will only work until November 2017 when Firefox 57 comes out. But long before that time, the new version will have evolved with more features. Note that some features are not possible anymore due to Firefox's new addon ecosystem called WebExtensions. They are much more restricted than older addons (pre Firefox-57)