It is/not compatible Rated 5 out of 5 stars

Great add-on but a funny thing. I run the identical FF (9.0.1) on my PC and my Lap top. Is great on the laptop but shows as not compatible on the PC. Odd

This review is for a previous version of the add-on (2008.12.15). 

Thanks for your feedback Mal. To install this add-on you must be online. Firefox has to be able to communicate with the Mozilla servers to check the compatibility of the add-on before it will override the compatibility coded in the add-on and continue with the install. For more information visit http://support.mozilla.org/en-US/kb/Unable%20to%20install%20add-ons

Rated 4 out of 5 stars

It a fantastic add-on. But unfortunately it doesn't work on facebook inbox. like when sending a friend a message. I'm using firefox 5.01 final

This review is for a previous version of the add-on (2008.12.15). 

Rated 5 out of 5 stars

Awesome! Thanks so much! have been missing a great add-on like this for sometime! Thanks for taking the time to get this out there! A must have for anyone who psells thingz rong all the tyme! ;)

This review is for a previous version of the add-on (2008.12.15). 

Works Well Rated 5 out of 5 stars

Works a treat with FF 4.01 - very pleased to be able to spell the correct way again :-)

This review is for a previous version of the add-on (2008.12.15). 

Rated 5 out of 5 stars

Thanks for this. Was dissapointed that the other AU dictionary didn't work with newer firefox versions.

This review is for a previous version of the add-on (2008.12.15). 

Rated 5 out of 5 stars

Oh, thank God... I was worried the developer of the original AE extension was never gonna come forth and fix the FF4 compatibility issues.

This add-on seems to work perfectly fine for me... cheers mate!

This review is for a previous version of the add-on (2008.12.15).