Dead? Avaliado em 5 de 5 estrelas

I'm using firefox 6.0 and this add-on is marked as incompatible. Any update soon ?