To those tortured souls ... Avaliado em 1 de 5 estrelas

WARNING:
If you are among the group of people who just can not live with the updated (or: uphated) version, as well as they just can not live without the one-and-only version 1.3 (like myself), then DO NOT UPDATE your FIREFOX to 3.5.4 , it's not compatible any more ... so make sure you got your FEBE ready----