Still doesn't work with Firefox 20 Waardering 1 van 5 sterren

Just tested, and it's still doesn't work with Firefox 20, and after downgrading to Firefox 19.0.2 too. :'(
---------------------------------------
Ubuntu 12.04.2 LTS amd64

Deze gebruiker heeft een eerdere beoordeling van deze add-on.