Nog niet gewaardeerd

It kinda sucks that this extension can't be used with the Firefox 3 betas...

I mean, most of the people in the know, who would install this kind of thing, are on the betas, right?

Deze beoordeling betreft een eerdere versie van de add-on (2a6).