SHAME! Does NOT work on Snow Leopard! Waardering 1 van 5 sterren

Works great on WIndows 7 + firefox 4, does not on Snow Leopard with Firefox4.

Deze beoordeling betreft een eerdere versie van de add-on (0.9.3).