Please update Waardering 4 van 5 sterren

Can you please add support for OpenSolaris and update compatibility to Firefox 3.6?

Thanks.