598 მიმოხილვა
  • Fair warning for anyone thinking about using this addon, it will hold your browser hostage if you ever dare to disable and uninstall it. YouTube will not work even in safe mode if you disable this addon once installed. It's highly suspicious and I recommend that everyone reports it for investigation by Mozilla, as the developer so arrogantly wills us to.
  • Im using old version only youtube main page isnt working with blacklist everything seems to work on new youtube. 5 star addon. I didnt like they way you changed version but it wasnt a problem revert to previous version and everything is ok. I'll switch to new version when blacklist works again.
  • I recommend this add-on 👍
  • A wonder that this Extension is still recommended by Firefox.

    The Addon can't do anything is just usless, using older Versions doesnt work either.

    The Addon was very usefull before.
    Now it has a Dark mode and some Video features that are already included in Youtube.

    Upcoming Features like Downloading Youtube Videos is Useless because there are Plenty other Good Addons or Websites where you can download them.

    Only the blacklist feature was usefull but that got removed too.

    To the Author: Posting this Github link doens't give us our Functions back
    https://github.com/ParticleCore/Iridium/issues/737#issuecomment-541321036

    Edit: If the old version doesn't work either then not having the features anymore is the same thing, so what exactly are you complaining if nothing changed I have no idea, but you're free to complain about whatever you want even if it doesn't make any sense.
  • That's not how you transition. Not cool man. And not smart.
    https://github.com/ParticleCore/Iridium/issues/737#issuecomment-541321036
  • became useless overnight, not very wise
    https://github.com/ParticleCore/Iridium/wiki/Report-a-bug

    If you are using Nightly 72.0a1 then it's a Firefox bug that is causing problems: https://github.com/ParticleCore/Iridium/issues/788
  • Al intentar ver videos de youtube insertados en otras paginas no los carga ni deja visualizarlos se quedan en negro y tengo que limpiar la cache para que vuelvan a funcionar. esto me sucede desde la version 1.2.0.
    hola comentar que con la version 1.2.4 se SOLUCIONO el problema. gracias por tu trabajo ya que para mi este addon es indispensable para ver youtube. saludos
    https://github.com/ParticleCore/Iridium/wiki/Report-a-bug
  • Used to be good, now it isn't, removed all useful features.

    DO NOT UPDATE.

    Where can I download the old version?
    https://github.com/ParticleCore/Iridium/issues/737#issuecomment-541321036

    https://addons.mozilla.org/firefox/addon/particle-iridium/versions/
  • Unnecessary to release an in-development version without anything useful over a working extension. Developers could have waited for the features to be rebuilt before releasing.
    https://github.com/ParticleCore/Iridium/issues/737#issuecomment-541321036
  • I used this addon for a while, and I loved it, but the most recent update removed almost every feature and broke embedded youtube videos on other sites. If the issues are fixed, I would love to come back, but right now it just is not in a working state.
    https://github.com/ParticleCore/Iridium/wiki/Report-a-bug
  • EDIT: Thanks for the reply. I saw the link to some random reddit thread, but not that Github issue report. Refreshing with cache cleared (Ctrl+F5) with Iridium disabled/uninstalled immediately fixed the issue. Why reply to all of these users having this issue with these wordy responses when this is all you have to do?

    Still, Iridium must have corrupted something in the site's cache, as no issue existed until I installed/enabled it for the first time in months (when I started using Enhancer instead). There's no way I'm going to blame the website for behavior that only occurs immediately after installing and uninstalling an extension, with no change in website coding, browser version, etc.

    Updating review to 3 stars because of the feature evaporation (why not restore more functionality before releasing the code rewrite?). But for anyone else affected by this, try Ctrl+F5 for a full refresh while Iridium is uninstalled/disabled, and you should be good to go.

    EDIT 2: Also, while trying to call me out for not using Reddit's search function (which is known to be garbage, by the way lol), you link to two threads, neither of which are referring to the issue I had. Guess you never looked at the screenshot I provided. If installing and uninstalling your addon immediately creates an issue that requires clearing the cache to fix, the addon is at fault. Obviously. Also, I didn't say this addon was malware, I said the behavior was on the same tier as that of malicious software (that is, 'things break if you remove it').

    ***

    So yeah, was using Enhancer for YouTube for a long time with Iridium also installed, but disabled, since I liked Enhancer's feature set more, and figured running them both at the same time would cause conflicts.

    Saw that Iridium had a bunch of updates recently, so I decided to try it out again. So I disabled Enhancer and enabled this. Saw many features were missing, so I swapped back. And the INSTANT I re-disabled Iridium, YouTube videos will NOT load at all, even if I restart Firefox in safe mode! Instead, the video area is completely empty, same color as the background, etc. Screenshot: https://i.imgur.com/al4WyRE.png ) The only way YouTube videos will load again is if I re-enable Iridium, and keep it re-enabled, even though it clashes with Enhancer when that's enabled too (e.g. videos will not autoplay with both extensions active, no matter what options I set). This all happened today, no Firefox updating occurred in between, nothing. YouTube broke as soon as Iridium was disabled. In fact, now, YouTube will never work while in safe mode, which obviously wasn't the case before. Uninstalling it completely gives the same result as disabling.

    I see you reacting to other reviewers saying that there's no way disabling Iridium broke anything, that having it installed was taking care of some bug in the browser (and that reddit link does not at all describe the issue, which is that videos don't load AT ALL, it's not some FPS issue). But this is definitely the culprit. I don't know HOW uninstalling an extension managed to break the website it interacts with, but it did, 100%. Find out why, and fix it. Reporting the addon for abuse in the meantime, this is malware-tier behavior.
    You can report whatever you want to report, but Mozilla will reply back explaining what I already have explained: no extension hosted on the AMO store can affect anything on the browser after it has been disabled and the browser restarted.

    I did not say having the extension installed took care of the bug, I said that it was making it work because whatever problem YouTube has was being circumvented as a result of the features the extension implements in their own source code. It was a fortunate coincidence for those that want to keep using the extension.

    You saw my replies to other users, but you also ignored that they confirmed the issue went away despite the fact that nothing had been changed in the extension.

    Futhermore, it was reported and confirmed as a YouTube bug in the repository itself:

    https://github.com/ParticleCore/Iridium/issues/771

    It's your choice to report this for whatever reason you want, but like I said, what you have is a YouTube bug and there's nothing this extension can do to cause that after it has been disabled. Follow the suggestions others posted on that Reddit post and I'm sure the issue will go away. If it doesn't then report to the YouTube team.

    Also, there's a search feature in Reddit which - had you actually used it instead of coming back here with such a vendetta - you'd find others reporting the video not working exactly like you described:

    https://www.reddit.com/r/youtube/comments/djlmht/bug_every_video_loads_like_this_just_a_blank/

    and another

    https://www.reddit.com/r/youtube/comments/diy8ro/bug_love_youtubes_new_minimalistic_design/

    But what do I know, I just do this for more than 5 years, it's way more likely that I've suddendly decided to make a malware-tier extension that just breaks YouTube (what would be the point?) rather than this being an actual YouTube bug like usual.
  • I can't believe new updates remove old features, this is ridiculous. I can't even install old versions of this addon because firefox figures them out as too old and automatically uninstall them.
    https://github.com/ParticleCore/Iridium/issues/737#issuecomment-541321036