Handy Assegnate 5 su 5 stelle

Nice work.

By the way, your most recent version is not compatible with Firefox 3.5.2
3.0.*
It appears to be working fine with the max version number bumped up.