Make an updatedversion for 3.6.8!!!!! Noté 1 sur 5 étoiles

I was just looking for something exactly like this and I find it, but I can't use it because I have FF version 3.6.8 There are too many add-on that this version of Firefox cannot use. . .that's sad.