Noté 5 sur 5 étoiles

best try

Cette critique concerne une version précédente du module (5.1.1). 

Noté 5 sur 5 étoiles

Please update for Firefox 57 and beta for Android. Thank you!

Cette critique concerne une version précédente du module (5.1.1). 

Firefox 57 Noté 5 sur 5 étoiles

I have followed the instructions but it does not work with Firefox Quantum 57+.

It shows a message and says that the extension is not compatible with Firefox 57, i've enabled the extensions legacy, restarted the browser and it failed on Quantum.

On Firefox Dev edition it worked well.

Cette critique concerne une version précédente du module (5.1.1).  Cet utilisateur a une revue précédente sur ce module.

Firefox Developer Edition = "Blueish" Quantum :)

Instructions on https://noscript.net/faq#qa2_1 explains that you need a blueish 57 (Firefox Dev Edition) or 58 (Nightly) for the extensions.legacy.enabled preference to work. Beta ("orange" 57) doesn't work.

RIP Firefox Noté 5 sur 5 étoiles

Interesting that this'll be able to run on dev builds come 57+, why won't Mozilla allow stable builds "hybrid Web Extensions"?

No matter, Firefox'll lose so many extensions it'll be obsolete anyway.

Cette critique concerne une version précédente du module (5.1.1).  Cet utilisateur a 2 revues précédentes sur ce module.

Not for people who work Noté 2 sur 5 étoiles

Had to uninstall it. It keeps me more busy than my work with all those problems it creates.

Cette critique concerne une version précédente du module (5.1.1). 

With new update NoScript icon has again disappeared! Noté 3 sur 5 étoiles

I like NoScript. I don't find it difficult to use at all and have no popups from it.
But I get tired of periodically losing my icon from the top of the page! I lost it AGAIN yesterday! How do I get it back? I've tried everything in "options".

Cette critique concerne une version précédente du module (5.1.1). 

Obnoxiously efficient and attention whoring Noté 2 sur 5 étoiles

Efficient ? Yeah I trust these many positive reviewers.

Personally I'm done knocking it off whenever I want to click a facebook [Share] button or the like on a third party site.

And I'm done having my browsing hijacked by a sudden page or dialogue begging for a donation or me looking into a changelog.
Yes Mr Dev, you positively deserve some compensation for your work, but your software is taking a crap on my focus every now and then.

The multi-stage XSS warning is a PITA and pops everywhere on the web. I'm SURE the interwebs are that dirty-unsecure. But at some point I need some usability.
I couldn't customize my safety/UX compromise satisfyingly enough (and I didn't try too hard because I don't think I should spend hours on it).
Despite going the "I know I'm potentially screwing myself" path through warnings, stuff is still blocked.

Oh and it sometimes breaks the UX in subtle ways.
"Oh. So that site isn't just broken junk then ?"

As a dev and rather cautious individual I known I'd better try and customize those XSS recognition patterns.
As a non-web dev I have yet to understand XSS in depth and it's not on the top of my TODO stack.

Great software, for the paranoid and the masochist. Not for my dumb use case.

EDIT: So why *such* a poor rating ?
Autonomously hacking 3rd party software for more security is HARD. Granted.
To use NoScript efficiently though, it takes a rather insane amount of patience and commitment (I don't even fancy what it's like for non-tech-savvy users).
If I'd install NoScript on my parents' computer, they'd toss Firefox altogether for that unpatched IE sitting around.
Oh and... that occasional yet obnoxious NoScript popup, FFS.

Cette critique concerne une version précédente du module (5.1.1). 

THX Giorgio! Noté 5 sur 5 étoiles

We all know that NoScript is an unmissable piece of kit. And we also know that it's the addons, like NoScript, that makes people come back to FireFox (looking at you Mozilla!).
But all good and well, talking addons, let's not forget the support separates the grey beards from the clean shaven youngsters. Issue with NoScript? Giorgio solved it (almost) before I could report it!
Mille, mille grazie Giorgio! ☺

Cette critique concerne une version précédente du module (5.1.1). 

Wait for version for Firefox 57 :I Noté 4 sur 5 étoiles

This is the best Firefox add-on to block scripts.
No other AddOn delivers the scope and ease of use like NoScript.
I hope an update for Firefox 57+ will be released soon to reuse NoScript.

Cette critique concerne une version précédente du module (5.1.0). 

"Blueish" Firefox 57+ builds can already be used with NoScript

See https://noscript.net/faq#qa2_1 for details.

NoScript is a MUST! Noté 5 sur 5 étoiles

One of the absolute best, and a total necessity!

Will there be a WebExtension version of NoScript? If so, same name used, or...because would not want to be without this extension.

Please, let us know if this addon will be 57+ compatible.

Thank you, superb work!

Cette critique concerne une version précédente du module (5.0.10). 

57b3 please!!! Noté 5 sur 5 étoiles

really need this one, good one!

Cette critique concerne une version précédente du module (5.0.10). 

Quality Security Add-on Noté 5 sur 5 étoiles

I've been using NoScript for a couple of years. It boggles the mind to think I ever surfed the web without a program like NoScript. It definitely keeps the nonsense and dangers of the internet at bay. And it has certainly given me loads of insight into the functionality of many websites. 5/5

Cette critique concerne une version précédente du module (5.0.10). 

make it compatible with firefox 57! Noté 5 sur 5 étoiles

please make it aviable for FF 57 can't browse w/o an scrip blocker

Cette critique concerne une version précédente du module (5.0.10). 

privacy and security NO1 app Noté 5 sur 5 étoiles

privacy and security NO1 app

Cette critique concerne une version précédente du module (5.0.10). 

Really good addon Noté 5 sur 5 étoiles

I've found that using NoScript and nukeanythingenhanced has really helped my web browsing experience for the better. I enjoy mostly text based browsing and with noscript I can do that much better

Cette critique concerne une version précédente du module (5.0.10).  Cet utilisateur a une revue précédente sur ce module.

Most important one Noté 5 sur 5 étoiles

This is the most important addon for firefox

Cette critique concerne une version précédente du module (5.0.10).  Cet utilisateur a une revue précédente sur ce module.

Noté 5 sur 5 étoiles

Bbnn

Cette critique concerne une version précédente du module (5.0.10). 

Noté 5 sur 5 étoiles

Génial! Facile à utiliser et on voit tout. Toutes les ruses des grands sites pour nous catcher... Merci !

Cette critique concerne une version précédente du module (5.0.10). 

Update addon please Noté 5 sur 5 étoiles

Update to latest firefox

Cette critique concerne une version précédente du module (5.0.10). 

Amazing Noté 5 sur 5 étoiles

Its an amazing script.

Cette critique concerne une version précédente du module (5.0.10).