Historique de version de Greasemonkey

71 versions

Méfiez-vous des anciennes versions !

Ces versions sont affichées pour informations et à titre d’essais. Vous devriez toujours utiliser la dernière version d’un module.

Version 2.2beta2 293.3 KiB Fonctionne avec Firefox 29.0 et supérieures

Version 2.2beta1 291.4 KiB Fonctionne avec Firefox 29.0 et supérieures

Version 2.1beta1 290.7 KiB Fonctionne avec Firefox 29.0 et supérieures

Version 2.0beta2 286.7 KiB Fonctionne avec Firefox 29.0 et supérieures

Version 2.0beta1 286.7 KiB Fonctionne avec Firefox 29.0 et supérieures

Version 1.16beta6 281.7 KiB Fonctionne avec Firefox 27.0.* et supérieures

Version 1.16beta5 281.7 KiB Fonctionne avec Firefox 27.0.* et supérieures

Version 1.16beta4 281.6 KiB Fonctionne avec Firefox 27.0.* et supérieures

Version 1.16beta3 281.4 KiB Fonctionne avec Firefox 27.0.* et supérieures

Version 1.16beta2 281.1 KiB Fonctionne avec Firefox 27.0.* et supérieures

Version 1.15beta2 280.7 KiB Fonctionne avec Firefox 20.0 et supérieures

Version 1.15beta1 280.9 KiB Fonctionne avec Firefox 20.0 et supérieures

Version 1.14beta1 280.6 KiB Fonctionne avec Firefox 20.0 et supérieures

Version 1.13beta6 280.7 KiB Fonctionne avec Firefox 20.0 et supérieures

Version 1.13beta5 280.6 KiB Fonctionne avec Firefox 20.0 et supérieures

Version 1.13beta4 279.6 KiB Fonctionne avec Firefox 20.0 et supérieures

Version 1.13beta3 279.4 KiB Fonctionne avec Firefox 20.0 et supérieures

Version 1.13beta2 280.4 KiB Fonctionne avec Firefox 20.0 et supérieures

Version 1.13beta1 279.3 KiB Fonctionne avec Firefox 20.0 et supérieures

Version 1.12beta3 275.9 KiB Fonctionne avec Firefox 20.0 et supérieures

Version 1.11beta1 269.0 KiB Fonctionne avec Firefox 14.0 et supérieures

Version 1.10beta1 264.6 KiB Fonctionne avec Firefox 14.0 et supérieures

Version 1.9beta2 263.1 KiB Fonctionne avec Firefox 14.0 et supérieures

Version 1.9beta1 263.1 KiB Fonctionne avec Firefox 14.0 et supérieures

Version 1.8beta3 262.7 KiB Fonctionne avec Firefox 14.0 et supérieures

Version 1.8beta2 261.8 KiB Fonctionne avec Firefox 14.0 et supérieures

Version 1.8beta1 238.5 KiB Fonctionne avec Firefox 14.0 et supérieures

Version 1.5beta2 237.7 KiB Fonctionne avec Firefox 14.0 et supérieures

See the Github milestone for the issues addressed in this release.

https://github.com/greasemonkey/greasemonkey/issues?milestone=44&state=closed

Version 1.5beta1 255.8 KiB Fonctionne avec Firefox 14.0 et supérieures

See the Github milestone for the issues addressed in this release.

https://github.com/greasemonkey/greasemonkey/issues?milestone=44&state=closed

Version 1.0beta7 260.0 KiB Fonctionne avec Firefox 14.0 et supérieures

Enhancements:
* New metadata, @grant, specifies which special APIs a user script will
have access to. Specifying "@grant none" means no special API access, and
thus no security restrictions. See http://wiki.greasespot.net/@grant
* The metadata @unwrap has been removed, as being unwrapped is now the default.
The wrapper will still be applied to scripts that have a "return" statement outside
of any function, but this may be removed in the future, so make sure your scripts
don't do this.
* Require at least Firefox 14.0 (no more Firefox 3 compatibility).
* Scripts that "@run-at document-start" have a valid document object to modify,
E.G. for adding <style> tags; but still before any part of the document is
loaded.
* GM_xmlhttpRequest() accepts a "timeout" option.
* GM_getResourceURL() works with a special protocol handler. (This is more
efficient/faster than the data: URI encoding used previously.
* The standard Firefox web developer console works for "console.log()" et al.
* Error reporting is much more consistent and obvious than in the past.

Bug fixes:
* Scripts with missing or broken "==UserScript==" metadata will work.
* The "alert()" workaround (see http://bugzil.la/647727) is not applied for
Firefox versions that do not exhibit this bug.
* When downloading a script not encoded in UTF-8, display an error message to
the user (rather than failing silently).
* The "show script" button in the install dialog is disabled until the download of
the script file is complete.