Historique de version de Grammalecte [fr]

27 versions

Méfiez-vous des anciennes versions !

Ces versions sont affichées pour informations et à titre d’essais. Vous devriez toujours utiliser la dernière version d’un module.

Version 0.6.5.1 4.1 MiB Fonctionne avec Firefox pour Android 56.0 et supérieures, Firefox 56.0 et supérieures

[Mise à jour] Correcteur grammatical.
[Mise à jour] Dictionnaire orthographique.
[Mise à jour] Interface légèrement revue.
[Corrections] Bugs mineurs.

Version 0.6.4 2.3 MiB Fonctionne avec Firefox 56.0 et supérieures

[amélioré] Suggestion orthographique.
[nouveau] Répercussion des corrections dans les nodes HTML éditables.

Version 0.6.3.1 2.3 MiB Fonctionne avec Firefox pour Android 56.0 et supérieures, Firefox 56.0 et supérieures

[Corrigé] bug de chargement du dictionnaire personnel.

Version 0.6.3 2.3 MiB Fonctionne avec Firefox pour Android 56.0 et supérieures, Firefox 56.0 et supérieures

[Mise à jour] Correcteur grammatical.
[Mise à jour] Dictionnaire orthographique.
[Corrections] Bugs mineurs.
[Nouveau] Éditeur lexical (β)

Version 0.6.2.1 2.3 MiB Fonctionne avec Firefox pour Android 56.0 et supérieures, Firefox 56.0 et supérieures

[Corrigé] Bug de mémorisation des options grammaticales.
[Corrigé] Suggestions orthographiques avec le dictionnaire personnel activé.

Version 0.6.2 2.3 MiB Fonctionne avec Firefox pour Android 56.0 et supérieures, Firefox 56.0 et supérieures

[Mise à jour] Correcteur grammatical.
[Mise à jour] Dictionnaires orthographiques.
[UI] Modification du panneau principal.
[Nouveau] Éditeur lexical (préversion) : Fabrique du dictionnaire personnel (requiert de nouveaux droits pour être exporté sur votre disque dur).

Version 0.6.1 2.3 MiB Fonctionne avec Firefox 56.0 et supérieures

[Mise à jour] Correcteur grammatical.
[Mise à jour] Dictionnaire orthographique.
[Nouveau] Détection de locutions dans le lexicographe.
[Amélioré] Moteur de suggestion du correcteur orthographique.
[Corrigé] Quelques bugs de l’interface.

Version 0.6.0.7 2.1 MiB Fonctionne avec Firefox 56.0 et supérieures

[Mise à jour] Correcteur grammatical
[Corrigé] Extrême lenteur du moteur de suggestions orthographique dans certains cas
[Interface] Stabilisation de l’apparence des panneaux

Version 0.6.0.5 2.1 MiB Fonctionne avec Firefox 56.0 et supérieures

[Mise à jour] Correcteur grammatical
[Corrigé] fenêtres de correction vides dans certains cas
[Corrigé] UI: apparition inappropriée du bouton de menu
[Corrigé] UI: décalage du tooltip lorsque la fenêtre est placée en haut ou en bas
[Corrigé] UI: dépassement du cadre du panneau
[Corrigé] UI: taille du bouton et du spinner
[Corrigé] UI: modification de l’alignement des paragraphes
[Corrigé] UI: espace interligne des paragraphes et taille des surlignements

Version 0.6.0.1 2.1 MiB Fonctionne avec Firefox 56.0 et supérieures

— Première version WebExtension finalisée (compatible Fx 56+).
— Interface améliorée.
— Mise à jour du dictionnaire.
— Mise à jour du correcteur grammatical.
— Meilleur moteur de suggestions pour les erreurs grammaticales.
— Nouveau moteur de suggestions pour les erreurs orthographiques.
— Pas de dictionnaires orthographiques inclus: proscrits par Firefox pour l’instant.

Version 0.6.0 2.1 MiB Fonctionne avec Firefox 57.0 et supérieures

— Compatible avec Firefox 57+.
— Nouvelle interface graphique.
— Mise à jour du correcteur grammatical.
— Pas de dictionnaires orthographiques inclus: désormais proscrits par Firefox.

Version 0.5.18 4.4 MiB Fonctionne avec Firefox 52.0 - 56.*

[Mise à jour] Dictionnaires orthographiques.
[Mise à jour] Correcteur grammatical.
[Nouveau] Normalisation Unicode NFC.
[Nouveau] Bouton pour débloquer la zone de texte.
[Modifié] Panneau grammatical : refonte de l’interface.
[Modifié] Conjugueur : ajustements de l’interface.
[Modifié] Lexicographe : prise en compte de la ponctuation.
[Modifié] Panneau principal : ajustements de l’interface.

Version 0.5.15.1 2.9 MiB Fonctionne avec Firefox 45.0 - 56.*

[Corrigé] Erreurs grammaticales invisibles.

Version 0.5.15 2.9 MiB Fonctionne avec Firefox 45.0 - 56.*

[MàJ] Correcteur grammatical.
[MàJ] Dictionnaires.

Version 0.5.14 3.1 MiB Fonctionne avec Firefox 45.0 - 56.*

[MàJ] Dictionnaires
[MàJ] Correcteur grammatical

Version 0.5.13 3.1 MiB Fonctionne avec Firefox 45.0 - 56.*

[MàJ] Correcteur grammatical.
[MàJ] Dictionnaires orthographiques.

Version 0.5.12.1 3.3 MiB Fonctionne avec Firefox 45.0 - 56.*

[Corrigé] Bug du moteur de suggestions.

Version 0.5.12 3.3 MiB Fonctionne avec Firefox 45.0 - 56.*

[Corrigé] Distorsion du panneau principal.
[MàJ] Dictionnaires orthographiques.
[MàJ] Correcteur grammatical.

Version 0.5.11 3.2 MiB Fonctionne avec Firefox 45.0 - 56.*

[MàJ] Dictionnaires.
[MàJ] Correcteur grammatical.

Version 0.5.10 3.2 MiB Fonctionne avec Firefox 45.0 - 56.*

[Corrigé] Formateur de texte.

Version 0.5.9.1 3.2 MiB Fonctionne avec Firefox 45.0 - 56.*

[Corrigé] Couleur des polices de caractères sur les thèmes de bureau sombres.
[Corrigé] Bug des étiquettes dans le lexicographe.
[MàJ] Correcteur grammatical.
[MàJ] Dictionnaires.

Version 0.5.8 3.2 MiB Fonctionne avec Firefox 45.0 - 56.*

[Corrigé] Fonctionnement en mode navigation privée
[Modifié] Options par défaut
[MàJ] Moteur grammatical
[MàJ] Dictionnaire

Version 0.5.7 3.1 MiB Fonctionne avec Firefox 45.0 - 56.*

[Corrigé] URL modifiées par le formateur de texte.

[MàJ] Correcteur grammatical
[MàJ] Dictionnaires.

Version 0.5.6 3.1 MiB Fonctionne avec Firefox 45.0 - 56.*

[Corrigé] Bug d’affichage du formateur de texte sur Linux.
[Corrigé] Sélecteur de dictionnaires sur Linux.

[MàJ] Correcteur grammatical
[MàJ] Dictionnaires.

Version 0.5.5 3.1 MiB Fonctionne avec Firefox 45.0 - 56.*

Changements :
— des couleurs différentes selon le type d’erreurs, afin que ce soit plus lisible,
— la possibilité de rétracter les panneaux,
— possibilité de copier le texte dans le presse-papiers,
— le calibrage du moteur orthographique de suggestion en fonction des dictionnaires sélectionnés
— correction de bugs et de faux positifs,
— dictionnaires mis à jour.

Version 0.5.4 3.1 MiB Fonctionne avec Firefox 45.0 - 56.*

— Sélecteur de dictionnaires.
— Beaucoup moins de faux positifs.
— Modification du tokeniseur pour éviter l’analyse des hashtags et des hyperliens probables.
— Non-signalement de tous les sigles.
— Dictionnaires mis à jour.

Version 0.5.1 2.0 MiB Fonctionne avec Firefox 45.0 - 56.*