Noté 3 sur 5 étoiles

Looks good but there's no Firefox 3-3.5b4 support!