Can't install in FF 22.0 (even if the page Staates it's compatible) Noté 3 sur 5 étoiles

something is wrong. the button is grey. ff Version is 22.0. add-on info Staates it would be compatible with ff 15.0 - 25.0.

Cette critique est pour une version précédente du module (0.1.1). 

I recommend to check your other addons. Did you change UserAgent?