Please update! Noté 1 sur 5 étoiles

Please update this or any of the quit Firefox buttons to be able to work with Firefox version 30.0 and Android OS 4.4.3! Thanks! Yeah that was an accident... When I go to the install page for your Extension it says it's not available for my platform...?

Cette critique concerne une version précédente du module (  Cet utilisateur a une revue précédente sur ce module.

Please don't spam with multiple reviews

Personally, I only own and provide QuitNow. It works all the way up to version 33.0a1 at the moment, and on *all* Android OS versions.

I don't know what your issue is, but if you'd like to contact me, I provide my email link, located nearby.