Rated 5 out of 5 stars

Excellent add-on! As the author notes, this works fine with Firefox 3.5 if you set extensions.checkCompatibility to false.

This review is for a previous version of the add-on (0.3.2).