Puntuado con 5 de 5 estrellas

Why does it say incompatible with Firefox 4.0.1 ?

Esta valoración es de una versión anterior del complemento (3.1-signed.1-signed).  Este usuario tiene 3 valoraciones anteriores de este complemento.