i am using firefox version 10 - no problem with this add-on ! Puntuado con 5 de 5 estrellas

i am using firefox version 10 - no problem with this add-on !

Esta valoración es de una versión anterior del complemento (0.3.1-signed).  Este usuario tiene una valoración anterior de este complemento.