Needs Firefox 19 update Puntuado con 5 de 5 estrellas

Great program but needs to be updated to FF19. Mozilla should stop these constant updates. It is killing add-ons. I still give it 5 stars. After all it is hardly the developer's fault that mozilla now has this stupid policy.

Dear mig, please update it ASAP. I can't live without this add-on.

Esta valoración es de una versión anterior del complemento (4.9.13). 

Can you give a try with this beta version http://www.downloadhelper.net/install-beta.php?version=4.9.14b1 and report if it fixes the problem in the bugzilla interface http://bugzilla.downloadhelper.net:8080/show_bug.cgi?id=496
Thanks.