Ver 3.0.1 can't use in imeem Puntuado con 4 de 5 estrellas

I use firefox on ubuntu 7.10
Version 3.0.1 can't download song from www.imeem.com
So I come back to use Version 2.6.1

Esta valoración es de una versión anterior del complemento (3.0.1). 

Re: Ver 3.0.1 can't use in imeem

This problem has been solved and the fix will be released soon.
Alternatively, you can install a test version from http://www.downloadhelper.net/install-beta.php?version=3.0.2b3