1.247 revisiones
  • Doesn't work, fail's persistently.
  • i like the older version better
    Unfortunately legacy AVD is not supported by new Firefox versions.
    Meanwhile all features were maximally ported to the new AVD.
  • Best aps for mozilla.
    We are grateful for your report and rating!
  • top
    Thank your for your report and rating!
  • 比较好用的一个插件
    Thank you!
  • best to use remember the AVD installer must be used with this extention!!
    Thank you for your report and rating!
    AVD installer is used to support streaming downloads.
  • Necesita un programa adicional para que funcione.
    Unfortunately since Firefox 57 some AVD features are available only with additional companion software.
  • This one works.
    Thank you for your report and rating!