RE: Updated version Puntuado con 4 de 5 estrellas

> Need that updated version for Firefox 3...

No,you don't. It's built into Firefox 3