FF 4.0 - PLEASE Puntuado con 5 de 5 estrellas

I love the app - but its incompatible with FF 4

Please UPDATE, Thanks.

why on earth didn't Mozilla include this in the new buttons for FF4 ?????

Este usuario tiene otras valoraciones de este complemento.