Tab Mix Plus -- Can't Use Firefox Without It Puntuado con 5 de 5 estrellas

Tab Mix Plus not compatible with Firefox 17! I too downloaded the development version. Can't use Firefox without Tab Mix Plus! Love it!

Esta valoración es de una versión anterior del complemento (0.4.0.3).