Compatibility Puntuado con 2 de 5 estrellas

Need compatibility with FF 3.5, please.