3.5 update problem Puntuado con 5 de 5 estrellas

Excellent extension that I really rely on, which is why I felt the need to review, because it no longer function with Firefox 3.5! lol Compatibility check is fine, but the functionality is simply absent now. :/