Puntuado con 3 de 5 estrellas

I second Vlada011`s comment. Please upgrade to be compatible with Firefox 4. (On your on time, of course)

Esta valoración es de una versión anterior del complemento (0.9.0).  Este usuario tiene una valoración anterior de este complemento.