Firefox ESR Puntuado con 5 de 5 estrellas

This is a fantastic add-on, but I have just started to use Firefox ESR version 17.0.5 and this add-on is no longer compatible. Is there any chance you would be able to make it compatible with Firefox ESR as I would hate to loose this excellent program.

Esta valoración es de una versión anterior del complemento (0.3.7). 

Self-Destructing Cookies is an SDK-based add-on. The SDK only officially supports the latest two versions of Firefox at the time it is released, so I'm limited to the same two-version window if I want to keep up with Firefox. Did you try installing it anyway? It might still work, especially older versions such as 0.3.6. You may have to disable compatibility checking as outlined here:

http://kb.mozillazine.org/Extensions.checkCompatibility