Puntuado con 5 de 5 estrellas

Thank you for updating it. Now I can switch completely to Firefox 4.

Esta valoración es de una versión anterior del complemento (1.4.1-signed.1-signed). 

Puntuado con 4 de 5 estrellas

Please update for Firefox 4. It is the only extension I need keeping me from switching to Firefox 4.

Esta valoración es de una versión anterior del complemento (1.3.7). 

Puntuado con 5 de 5 estrellas

Good and useful addon.

Please update it to work with Firefox 4, this is the one extension keeping me from switching to Firefox 4.

Esta valoración es de una versión anterior del complemento (1.3.7). 

Puntuado con 5 de 5 estrellas

Good addon.

Please update it to work with Firefox 4.

Esta valoración es de una versión anterior del complemento (1.3.7).