Puntuado con 5 de 5 estrellas

Good and useful addon.

Please update it to work with Firefox 4, this is the one extension keeping me from switching to Firefox 4.

Esta valoración es de una versión anterior del complemento (1.3.7).  Este usuario tiene otras valoraciones de este complemento.