Runs fine on Firefox 4.0 beta 12 Puntuado con 5 de 5 estrellas

Runs fine on Firefox 4.0 beta 12 provided as always that install.rdf be modified accordingly to new version.
A relief because I use this extension extensively, I'm very fond of the new FF 4, and many extensions have still not been updated.