Puntuado con 1 de 5 estrellas

Using FF 16 and it doesn't work. Guess there's no more update done.

Esta valoración es de una versión anterior del complemento (1.1.0).