Good but.... Puntuado con 4 de 5 estrellas

is not compatible wit Firefox 6xx and 7xx!!!! Please update it

Esta valoración es de una versión anterior del complemento (1.3.2.1-signed.1-signed).