Puntuado con 5 de 5 estrellas

works with firefox12, i updated firefox on ubuntu12.04 and its working