Alternative plugin for FF 4.0.1 Puntuado con 5 de 5 estrellas

Schubert works fine with FF 4.0.1 on Mac Intel OSX 10.5.8 - just tried it
schubert-it.com/pluginpdf/