Puntuado con 3 de 5 estrellas

Please can you make it compatible with FF3.1beta 3 ?

Esta valoración es de una versión anterior del complemento (1.93.2.1). 

Yup

It's coming soon. Within a week I will post an update to my website, and then make it available from addons.mozilla.org some time thereafter (depending on user feedback).