Puntuado con 5 de 5 estrellas

Worked Firefox 12.0
my firefox is Firefox 3.5.3
Please Make it go with all versions.

Make to Works
(Works with Firefox 3.0 and Firefox 12.0)

Esta valoración es de una versión anterior del complemento (0.9.8.1-signed).