Puntuado con 5 de 5 estrellas

Compatible with Firefox 4.0
In fact.. I'm using it right now with nightlies :D