Historial de versiones de Leak Monitor

15 versiones

¡Ten cuidado con las versiones antiguas!

Estas versiones se muestran con propósitos de referencia y pruebas. Debes usar siempre la última versión de un complemento.

Versión 0.4.6 155.6 kB Funciona con Firefox 4.0b11 - 4.0.*

Update for compatibility with Firefox 4 (and drop compatibility with older versions).

Versión 0.4.5 152.6 kB Funciona con Firefox 3.1b3 - 4.0b2pre

Fix binary compatibility with newer alphas of 1.9.3.

Versión 0.4.4 151.6 kB Funciona con Firefox 3.1b3 - 3.6.*

Versión 0.4.3 151.6 kB Funciona con Firefox 3.1b3 - 3.5b4

Versión 0.4.2 149.5 kB Funciona con Firefox 3.0b4pre - 3.1a2pre

This version fixes a common hang in 0.4.1. It also enumerates the properties of JS objects in a less intrusive way.

It is marked as compatible with all Gecko toolkit applications.

It adds Greek, Dutch, and Catalan localizations.

Versión 0.4.1 148.5 kB Funciona con Firefox 3.0b4pre - 3.0b4pre, Thunderbird 3.0a1 - 3.0a1

This version is updated to the trunk. It has a number of other major changes: it walks up the prototype chain to show all relevant properties, it considers all JS roots in the scope rather than just wrapped JS objects, and the storage mechanism is redesigned so that each alert shows the state at the time and continues to do so even if that state changes. This version adds Hungarian and Ukrainian translations.

Versión 0.3.6 96.3 kB Funciona con Firefox 1.5 - 3.0a1, Thunderbird 1.5 - 3.0a1

This version fixes a binary compatibility problem in the Linux binary component.

Versión 0.3.5 95.2 kB Funciona con Firefox 1.5 - 3.0a1, Thunderbird 1.5 - 3.0a1

This version fixes bug 358661 so that the alerts work again in 2.0 and trunk, adds Czech, Japanese, Spanish, and Italian localizations, and notes compatibility with Flock.

Versión 0.3.4 101.4 kB Funciona con Firefox 1.5 - 2.0, Thunderbird 1.5 - 1.5.0.*

French and German localizations added; a little other cleanup.

Versión 0.3.3 119.8 kB Funciona con Firefox 1.5 - 2.0, Thunderbird 1.5 - 1.5.0.*

This version adds x86_64 Linux support and updates the Russian localization.

Versión 0.3.2 95.2 kB Funciona con Firefox 1.5 - 2.0, Thunderbird 1.5 - 1.5.0.*

This version may fix additional false positives. However, more importantly, it will alert (Reclaimed Leak Alert) if any of the memory it previously reported as leaked has been reclaimed. So if you don't see the Reclaimed Leak Alert almost immediately, then it's probably a real problem. (Note that you may see the Reclaimed Leak Alert print to stdout during shutdown; it prints to the console instead of alerting during the quit process. If this happens, then it's definitely a real leak -- and one of the harder types to track down, since it's not actually still present at shutdown.)

Versión 0.3.0 93.2 kB Funciona con Firefox 1.5 - 2.0, Thunderbird 1.5 - 1.5.0.*

This version fixes some alerts that were false positives (were not really leaks).

Versión 0.2.0 92.2 kB Funciona con Firefox 1.5 - 2.0, Thunderbird 1.5 - 1.5.0.*

This version contains some crash fixes and adds the ability to copy the entire leak report to the clipboard. It also contains a Russian localization contributed by stoneflash.

Versión 0.1.3 82.9 kB Funciona con Firefox 1.5 - 2.0, Thunderbird 1.5 - 1.5.0.*

This version also claims Thunderbird compatibility. Again, it has a binary component for Windows-x86, Linux-x86, Mac OS X PPC, and Mac OS X Intel.

Versión 0.1.2 82.9 kB Funciona con Firefox 1.5 - 1.5.0.*

This contains a binary component for Windows-x86, Linux-i686, Mac OS X-PPC, and Mac OS X-Intel.