Problem with compatibility for Minefield Puntuado con 5 de 5 estrellas

I used this all the time but need to re-install for Minefield (FF 3.0.8) and the version that is supposed to be compatible will not download as I get an error message saying that it is not compatible :-(