Historial de versiones de FB Phishing Protector

15 versiones

¡Ten cuidado con las versiones antiguas!

Estas versiones se muestran con propósitos de referencia y pruebas. Debes usar siempre la última versión de un complemento.

Versión 4.4.3 86.0 kB Funciona con Firefox para Android 10.0a1 - 33.0, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

✓ Added internal blacklist for known phishing websites.

Versión 4.4.2 86.0 kB Funciona con Firefox para Android 10.0a1 - 24.0, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

✓ Fixed menu-item icon (Fx Android)

Versión 4.4.1 86.0 kB Funciona con Firefox para Android 10.0a1 - 24.0, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

✓ Fixed leak due to bug 753687

✓ Android Only: Added menu entry to quickly toggle the XSS/Tracking Protection (Ie, you'll still be warned about Phishing websites)

Versión 4.3.2 86.1 kB Funciona con Firefox para Android 10.0a1 - 23.0, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

✓ SAYoR'ed Updated GamersUnite/autoaccept.js script (Thanks to Chris Jackson)

✓ Fixed Error Console's Filter handling for Fx 18+

Versión 4.3.1 86.0 kB Funciona con Firefox para Android 10.0a1 - 21.0a1, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

Small fixes, mainly for SeaMonkey.

Versión 4.3 86.0 kB Funciona con Firefox para Android 10.0a1 - 21.0a1, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

✔ Added workaround for issue caused due no Content Policy Factory being unregistered when upgrading the add-on. This should only fix the problem with further updates, ie you'll still need to restart the browser when upgrading to this version.

✔ Fixed issue with the Tracking Protection feature which prevented the FB url from being manually entered into the url/location bar.

Versión 4.2.1 85.9 kB Funciona con Firefox para Android 10.0a1 - 18.0a1, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

✔ White-listed "akanoihd.net"

Versión 4.2 85.9 kB Funciona con Firefox para Android 10.0a1 - 19.0a1, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

✔ Implemented a Tracking Protection feature which when enabled will protect your privacy by blocking Facebook scripts while you are not in their website. This will forbid Like buttons and such from being run on 3rd part websites.

✔ Added option to turn off the "Protection Enabled" notification.

✔ Minor fixes.

Versión 4.1.2 85.0 kB Funciona con Firefox para Android 10.0a1 - 17.0a1, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

✔ Small fix for SeaMonkey 2.11

Versión 4.1 85.0 kB Funciona con Firefox para Android 10.0a1 - 17.0a1, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

✔ The Add-On is now Restartless.

✔ Compatibility with Firefox on Android and SeaMonkey.

✔ Improved Self Defense.

✔ Minor fixes/changes on the core functionality.

Versión 4.0 85.0 kB Funciona con Firefox para Android 10.0a1 - 16.*, Firefox 7.0 y posterior, Mobile 10.0a1 y posterior, SeaMonkey 2.3 y posterior

✔ The Add-On is now Restartless.

✔ Compatibility with Firefox on Android and SeaMonkey.

✔ Improved Self Defense.

✔ Minor fixes/changes on the core functionality.

Versión 3.0 84.0 kB Funciona con Firefox 3.6 y posterior

✓ Implemented a new white-list's scope which we'll name SAYoR (short for Scripts At Your Own Risk) where we'll white-list scripts comming from "userscripts" or add-ons NOT hosted on AMO. Those scripts while had to pass our validation to be whitelisted, we can't guarantee that future versions of them are safe to use as well.

✓ Implemented new notification mechanism by using Firefox's "PopupNotifications" module.

✓ Added options to enable/disable the SAYoR context and Popup Notification system to use, as usual go to the Add-On Manager to change them.

✓ Injections from iframes will be now reported on the parent window and thus the popup warning will be shown correctly centered on the webpage.

✓ Implemented internal storage engine to avoid reporting the same blocked script more than once per second. (All of them will still be logged on the ErrorConsole as they appear, though)

✓ Additional info will be logged on the ErrorConsole when an injection is blocked, such as the request origin or the location if within an iframe. Remember you can open the ErrorConsole at any time by using CTRL+Shift+J

✓ Whitelisted "dev.virtualearth.net" and "ecn.dev.virtualearth.net" globally (not only on stories.facebook.com - Thanks to Thomas B.)

✓ SAYoR'ed http://127.0.0.1:4001/isrunning as used by the cacaoweb add-on (Thanks to Lenard L.)

✓ SAYoR'ed GamersUnite/autoaccept.js?0.90 (Thanks to Carl M.)

✓ SAYoR'ed ajax.unfriendfinder/version=33 (Thanks to Heiko A.)

Versión 2.2 67.6 kB Funciona con Firefox 3.6 y posterior

✓ White-listed "dev.virtualearth.net" *while on* "stories.facebook.com" (Thanks to James L.)

✓ White-listed "js.cooliris.com" (Thanks to Evald R.) - Note: We've noticed scripts from this source have the ability to perform certain unsafe actions... However, that's a trusted company providing a privacy policy on how they use your data and thus we're white-listing it.

Versión 2.1 67.6 kB Funciona con Firefox 3.6 y posterior

✓ Replaced word "Malicious" by "Suspicious"

✓ Added "www.google.com" to the list of safe domains to inject scripts, since for example their recaptcha service is used on external websites to post comments.

Versión 2.0 67.6 kB Funciona con Firefox 4.0 y posterior