Puntuado con 2 de 5 estrellas

Can an updated version of this be made available? We could use a version that is compatible and tested with Firefox 3.6. Thanks.

Esta valoración es de una versión anterior del complemento (1.5.1.1-signed).