Puntuado con 5 de 5 estrellas

Yes, Please do make it compatible with Firefox 26, and any future versions. Best app of it's kind, and among the first things I always add back to my setup.

I consider it a necessity, and should be a part of any browsing experience.