Please bring back DLSB Puntuado con 5 de 5 estrellas

I too consider this a "must have" tool. I am getting so sick and tired of Firefox not taking the time to ensure compatibility before releasing updates. I use Kaspersky PURE 3.0 and half of my extensions are incompatible. FF is getting almost as bad as IE !!!