Does not work in 9.0.1 Puntuado con 1 de 5 estrellas

firefox 9.0.1
none of the described security options are checked, yet extension does not work