Puntuado con 5 de 5 estrellas

I also use it for a long time. It is broken in ff 26. Do not want live without it, downgrade to 25.

Maby the reason due Mozilla devs:
In the Firefox 26 release train, nsIDownloadManager will not be used anymore.
found on: https://wiki.mozilla.org/QA/Desktop_Firefox/Downloads.jsm

Esta valoración es de una versión anterior del complemento (0.9.8.1-signed).